# "Storage Initialization failed" error

## Issue

> The "Storage Initialization failed" error occurred.

***

## Cause

Apart from performing backups, operations such as browsing the storage are also handled by the **agents** — [**XMS**](#user-content-fn-1)[^1] **does not communicate with the storage directly**. When browsing a backup, the **default worker** indicates which device will perform the operation. If this device does not have the required access permissions to the storage, browsing will fail and the above error will appear.

***

## Resolution

1. Verify that the **default worker** has communication with the storage enabled.
2. Make sure that the storage configuration is correct, including storage access credentials and the path to the share.
3. Make sure that your device has a connection to the specified storage.

[^1]: Xopero ONE Management Service


---

# Agent Instructions: Querying This Documentation

If you need additional information that is not directly available in this page, you can query the documentation dynamically by asking a question.

Perform an HTTP GET request on the current page URL with the `ask` query parameter:

```
GET https://helpcenter.xopero.com/xopero-one-en/common-issues/workstations-and-servers/storage-initialization-failed-error.md?ask=<question>
```

The question should be specific, self-contained, and written in natural language.
The response will contain a direct answer to the question and relevant excerpts and sources from the documentation.

Use this mechanism when the answer is not explicitly present in the current page, you need clarification or additional context, or you want to retrieve related documentation sections.
